• Welcome to LiuJason's Blog!

标签:Rstudio

[已解决]Ubuntu18.04安装rgdal sf失败 configure: error: gdal-config not found or not executable

问题Ubuntu18.04安装rgdal sf失败,报错:configure: CC: gcc -std=gnu99configure: CXX: g++ -std=gnu++11checking for gdal-config... nonoconfigure: error: gdal-config not found or not……

Ubuntu18.04安装最新版本R (3.6.2) | 使用官方稳定版R源repo

前言Ubuntu自带的官方源一直是有长时间的发布延迟的,因此即使是R已经稳定版本发布到3.6.2了,官方源依旧是3.4版本….这里使用R的官方repo进行安装,实现Ubuntu18.04下安装最新稳定版的R(3.6.2)如果要在CentOS下安装ShinyServer,请查看这里:https://www.liujason.com/artic……

Ubuntu18.04安装最新R3.6+Rstudio-Server并使用Nginx开启SSL加密

前言实在受不了国内容器云的访问速度,于是在德国节点打算新建一个Rstudio服务器自用。之前尝试用CentOS8,发现自己常用的地理信息包GDAL无法支持,因此还是换用Ubuntu18.04。安装R的依赖环境由于Ubuntu自带的源R版本更新太慢了,所以这里用rstudio的源sudo apt-key adv --keyserver keyser……

CentOS8下安装GDAL最新版|rgdal安装失败解决方案

问题CentOS8下R安装包rgdal失败解决方案缺少最新版的GDAL,需要在Linux系统中编译安装即可。sudo yum groupinstall "Development Tools" -ysudo yum install wget -ysudo yum install postgresql postgresql……

CentOS8下安装和配置Rstudio-Server并使用Nginx实现SSL加密

前言实在受不了国内容器云的访问速度,于是在德国节点打算新建一个Rstudio服务器自用。CentOS8出来也有一段时间了,就用新版的CentOS8试试水吧。安装R的依赖环境首先需要安装epel库:yum install sudo wget -y && sudo yum install epel-release -y &&a……

[已解决]CentOS8下yum安装R报错 R-devel requires R-core-devel but none of the providers can be installed

问题CentOS8下yum安装R报错:[[email protected] ~]# sudo yum install R -yExtra Packages for Enterprise Linux Modular 8 - x86_64 59 kB/s | 40 kB 00:00 ……

CentOS7下安装R ShinyServer并配置git和监听端口/IP

前言原本我是不想写的,但是考虑到后续自己可能还会用到,还是记录一下吧。安装过程很简单就是添加源、装依赖、拉包并安装。可以参考rstudio的安装方法:https://www.liujason.com/article/121.html这次是在CentOS7的LXC中进行安装,为了做这个东西:https://r-shiny.liujason.com/sea……

在R中使用API将地名转换为经纬度坐标

最近在分析全球癌症发病率与特定地理位置直接的关系,用到了CI5数据集。但是这个数据集中只有癌症登记机构的地名信息,而进行分析的话需要用到坐标,因此需要将地名转换为经纬度坐标。这里我找到了一个非常棒的API,只要注册账号即可免费转换,每天限制1500条:注册地址:【已隐藏】注册后在账户中可以看到API Key,在每次curl请求的时候附上这个key即可。……

使用R进行多线程multithreading数据处理

最近拿到了SEER的癌症发病数据,准备做一些流行病学的分析。但是SEER提供的数据是经过编码的,如果不使用他们定制的分析软件就只能先自己转码后再进行分析。我还是更喜欢用R一些,所以果断选择后者。这套数据编码后能压缩掉不少空间,但是要分析的时候也挺麻烦的,由于是根据position来确定变量数值,因此解码就是把这些变量按position和length信息……

CentOS下手动编译安装指定版本的R|最新版本3.6.0

碰到一个客户必须要R3.6….然后没辙,只好给他装一个。顺便记录一下如何安装指定版本的R,要替换其他版本只需要代码中的3.6.0改掉就行了。<code><span class="pln">yum groupinstall "Development Tools" -yyum i……