• Welcome to LiuJason's Blog!

CentOS8下安装GDAL最新版|rgdal安装失败解决方案

Linux笔记 Jason 6 months ago (02-17) 597 Views 0 Comments QR code of this page
文章目录[隐藏]

问题

CentOS8下R安装包rgdal失败

解决方案

缺少最新版的GDAL,需要在Linux系统中编译安装即可。

sudo yum groupinstall "Development Tools" -y
sudo yum install wget -y
sudo yum install postgresql postgresql-devel proj proj-devel -y
#安装编译好的依赖libkml
wget http://s3.amazonaws.com/etc-data.koordinates.com/gdal-travisci/install-libkml-r864-64bit.tar.gz
tar xzf install-libkml-r864-64bit.tar.gz
sudo cp -r install-libkml/include/* /usr/local/include
sudo cp -r install-libkml/lib/* /usr/local/lib
sudo ldconfig
#安装GDAL,获取最新版本:http://download.osgeo.org/gdal/
wget http://download.osgeo.org/gdal/3.0.4/gdal-3.0.4.tar.gz
tar xzf gdal-* && rm gdal*.gz -f && cd gdal-*
#自己修改-j后的线程数
./configure --with-libkml && make -j 8 && make install
cp /usr/local/lib/* /usr/lib64/

尚未解决

checking for gdal-config... no

持续关注中….


This article is under CC BY-NC-SA 4.0 license.
Please quote the original link:https://www.liujason.com/article/534.html
Like (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址