CentOS7安装最新版本gsl库|GNU Scientific Library|R语言依赖库

更新,直接安装包到lib64下不行,实际上gsl在安装的时候会默认把各种lib装到不同的地方,所有在下面第4去掉,然后第5步直接把路径改为/usr即可:
5(新). ./configure –prefix=/usr

————
在安装R中的gsl包之前,我们需要在系统中安装gsl库。
然而!R中的gsl包对gsl库的版本要求是2.1以上,但是yum安装的话默认是1.5版本,因此要2.1以上的新版本需要自己编译安装,操作如下:
1. 首先下载最新的安装包:
wget ftp://ftp.gnu.org/gnu/gsl/gsl-latest.tar.gz
2. 解压
tar xzf gsl-latest.tar.gz
3. 进入路径下
cd gsl*
4. 新建一个安装路径,我这里就直接安装到lib下了
mkdir /usr/lib64/gsl
5. 设置安装路径
./configure –prefix=/usr/lib64/gsl
6. 编译安装
make
make install

说点什么

Please Login to comment
avatar
  Subscribe  
提醒