• Welcome to LiuJason's Blog!

CentOS 7禁止内核自动更新升级

Linux笔记 Jason 2 months ago (04-28) 276 Views 0 Comments QR code of this page

云筏的KVM系列服务器目前只支持默认版本的Linux内核,更换其他版本的内核可能会出现不兼容的情况,然后IO以及网络速度会变得特别慢。这个问题在产品文档中有专门说明,一般用户不要更新内核就没有问题了,如果用户有能力选择内核的话升级内核到特定版本也是可以正常使用的(需要自己多尝试)。

由于虚拟机业务不是云筏的主营,最近在准备把平台从WHMCS切换到Zkeys,这样虚拟业务和网络构架的开发全部交给Zkeys的工程师,减轻虚拟业务上的运维压力。因为目前整套方案(Proxmox+Virtualizor+WHMCS+KVM+NAT)都打算切换到Zkeys(Zkeys+KVM)所以这个旧方案的硬件兼容的问题不打算修复了。

CentOS系统会自动更新内核,这里给出一个禁止内核自动更新的方法 (Debian/Ubuntu请看这里:https://www.liujason.com/article/740.html)。

如果只是一次运行yum update,可以直接加exclude参数–exclude,将含有kernel字段的包排除:

sudo yum --exclude=kernel* update

但是如果是用脚本之类的会自动更新的话,就需要修改配置文件了。
编辑yum配置文件/etc/yum.conf,在[main]字段中添加以下内容

#禁止更新内核
exclude=kernel*
# 禁止更新系统
exclude=centos-release*

This article is under CC BY-NC-SA 4.0 license.
Please quote the original link:https://www.liujason.com/article/742.html
Like (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址