• Welcome to LiuJason's Blog!

CentOS下手动编译安装指定版本的R|最新版本3.6.0

Linux笔记 Jason 1 years ago (2019-05-22) 677 Views 1 Comments QR code of this page

碰到一个客户必须要R3.6….然后没辙,只好给他装一个。
顺便记录一下如何安装指定版本的R,要替换其他版本只需要代码中的3.6.0改掉就行了。

<code><span class="pln">yum groupinstall "Development Tools" -y
yum install -y wget sudo
wget https</span><span class="pun">://</span><span class="pln">cran.r</span><span class="pun">-</span><span class="pln">project.org</span><span class="pun">/</span><span class="pln">src</span><span class="pun">/</span><span class="pln">base</span><span class="pun">/</span><span class="pln">R</span><span class="lit">-3</span><span class="pun">/</span><span class="pln">R</span><span class="lit">-3.6.0</span><span class="pln">.tar.gz
tar zxvf R</span><span class="lit">*</span><span class="pln">.tar.gz
</span><span class="pln">cd R*</span><span class="pln">
.</span><span class="pun">/</span><span class="pln">configure</span><span class="pun">;</span><span class="pln"> make
</span><span class="pln">sudo make install</span></code>

This article is under CC BY-NC-SA 4.0 license.
Please quote the original link:https://www.liujason.com/article/281.html
Like (1)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(1)个小伙伴在吐槽
  1. Jason
    出现configure: error: --with-readline=yes (default) and headers/libs are not available报错的话在config的时候添加参数:./configure --with-x=no --with-readline=no
    Jason2019-05-22 20:53 Reply Windows 10 | Chrome 74.0.3729.157